import re
regex = re.compile(r"input..*(?<=name=['|\"])([\w]+)['|\"]")
test_str = ("<form method=\"post\" action=\"guardar.php\">\n"
" <input type=\"hidden\" name=\"produto1\" value=\"teste1\">\n"
" <input type=\"hidden\" name='produto2' value=\"teste2\">\n"
" <input name=\"produto3\" type=\"hidden\" value=\"teste3\">\n"
" <input type=\"hidden\" name='produto4' value=\"teste4\">\n"
" <input type=\"hidden\" name=\"produto5\" value=\"teste5\">\n"
"<input type=\"submit\" value=\"enviar\">\n"
"</form>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")