$re = '/(?=\S)[^\'"\s]*(?:\'[^\']*\'[^\'"\s]*|"[^"]*"[^\'"\s]*)*/';
$str = 'dateto:\'2015-10-07 15:05\' xxxx datefrom:\'2015-10-09 15:05\' yyyy asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);