re = /(?=\S)[^'"\s]*(?:'[^']*'[^'"\s]*|"[^"]*"[^'"\s]*)*/
str = 'dateto:\'2015-10-07 15:05\' xxxx datefrom:\'2015-10-09 15:05\' yyyy asdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end