// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"goTo(_[\S_]+)(_[\S_]+)(_[\S_]+)").unwrap();
let string = "param-out goTo goTo_6f7aaaab-8a2b-4654-9a51-eb590ec0f2b4_1_ddb34756-8194-4e5a-8aa9-12a755eff6c1 goTo-1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}