$re = '/[P]\W/m';
$str = 'P=0.0658
P>0.05
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);