const regex = /(?<=than\s)better(?=\sabsolutely)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=than\\s)better(?=\\sabsolutely)', 'g')
const str = `Imperfection is beauty, madness is genius and it’s than better to be absolutely ridiculous than better absolutely boring `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}