re = /(?<=than\s)better(?=\sabsolutely)/
str = 'Imperfection is beauty, madness is genius and it’s than better to be absolutely ridiculous than better absolutely boring '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end