package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([+-]?)([0-9]+)?w?\s*?(0?[1-9]|[12][0-9]|3[01])?d?\s*?([01]?[0-9]?|2[0-3])?h?\s*?([0-5]?[0-9])?m?$`)
var str = `-3w 4d 2h 1m
3w
4d
2h
1m
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}