const regex = /^([+-]?)([0-9]+)?w?\s*?(0?[1-9]|[12][0-9]|3[01])?d?\s*?([01]?[0-9]?|2[0-3])?h?\s*?([0-5]?[0-9])?m?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([+-]?)([0-9]+)?w?\\s*?(0?[1-9]|[12][0-9]|3[01])?d?\\s*?([01]?[0-9]?|2[0-3])?h?\\s*?([0-5]?[0-9])?m?$', 'gm')
const str = `-3w 4d 2h 1m
3w
4d
2h
1m
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}