import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{6}\\s*([^\\t]*?)\\s*\\t\\s*([^\\t]*)\\s*s0(\\d{6})@htw-berlin.de.*";
final String string = "\n"
+ "Nr MtkNr Name Vorname Email Studiengang Fachsemester Status\n"
+ " 1: 546254 Adiputro Axel Ferris s0546254@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 angemeldet \n"
+ " 2: 560996 Rachmatullah Fathoni s0560996@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 angemeldet \n"
+ " 3: 561110 Shcherban Oksana s0561110@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 10 angemeldet \n"
+ " 4: 569153 Wanat Philipp s0569153@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 angemeldet \n"
+ " 5: 572928 Staats Martin s0572928@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 angemeldet \n"
+ " 6: 573033 Trinh Quynh Vi Ngoc s0573033@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 7: 574074 Baliev Krist s0574074@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 3 angemeldet \n"
+ " 8: 575428 Seidel Richard s0575428@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 9: 575695 Valentin Leonard s0575695@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 10: 575730 Schuldt Jonah-Sophie s0575730@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 11: 575754 Blank Maximilian s0575754@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 12: 575868 Klingberg Paul s0575868@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet \n"
+ " 13: 576962 Strecker Ralf s0576962@htw-berlin.de Master IMI (M) H Wintersem. 2016 3 angemeldet \n"
+ " 14: 540347 Redanz René s0540347@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen \n"
+ " 15: 549481 Müller Nadja s0549481@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 15 zugelassen \n"
+ " 16: 550246 Ramadhan Irfan s0550246@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 17: 562212 Haseloff Moritz s0562212@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 10 zugelassen \n"
+ " 18: 564500 Voitel Justin s0564500@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen \n"
+ " 19: 565517 Ha Le s0565517@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 20: 565873 Al Mohamad Hasan s0565873@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen \n"
+ " 21: 566367 Baloska Diro s0566367@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen \n"
+ " 22: 568194 Kolev Dimitar s0568194@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 23: 568851 Springborn Kevin s0568851@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 24: 568927 Solihin Martin Christian s0568927@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 25: 570766 Alkhodor Salim s0570766@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 zugelassen \n"
+ " 26: 571336 Hedemann Katja Gertrud s0571336@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 zugelassen \n"
+ " 27: 572745 Pötsch Michelle s0572745@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 5 zugelassen \n"
+ " 28: 572933 Siewertsen Paul s0572933@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen \n"
+ " 29: 573063 Unverzagt Laura Laetitia s0573063@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 5 zugelassen \n"
+ " 30: 574153 Hahn Hendrik s0574153@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen \n"
+ " 31: 575518 Hintze Carolin s0575518@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen \n"
+ " 32: 575888 Katysheva Daria s0575888@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen \n"
+ " 33: 575923 Lüdecke Lukas Daniel s0575923@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}