import Foundation
let pattern = #"\d{6}\s*([^\t]*?)\s*\t\s*([^\t]*)\s*s0(\d{6})@htw-berlin.de.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Nr MtkNr Name Vorname Email Studiengang Fachsemester Status
1: 546254 Adiputro Axel Ferris s0546254@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 angemeldet
2: 560996 Rachmatullah Fathoni s0560996@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 angemeldet
3: 561110 Shcherban Oksana s0561110@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 10 angemeldet
4: 569153 Wanat Philipp s0569153@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 angemeldet
5: 572928 Staats Martin s0572928@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 angemeldet
6: 573033 Trinh Quynh Vi Ngoc s0573033@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
7: 574074 Baliev Krist s0574074@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 3 angemeldet
8: 575428 Seidel Richard s0575428@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
9: 575695 Valentin Leonard s0575695@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
10: 575730 Schuldt Jonah-Sophie s0575730@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
11: 575754 Blank Maximilian s0575754@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
12: 575868 Klingberg Paul s0575868@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 angemeldet
13: 576962 Strecker Ralf s0576962@htw-berlin.de Master IMI (M) H Wintersem. 2016 3 angemeldet
14: 540347 Redanz René s0540347@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen
15: 549481 Müller Nadja s0549481@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 15 zugelassen
16: 550246 Ramadhan Irfan s0550246@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
17: 562212 Haseloff Moritz s0562212@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 10 zugelassen
18: 564500 Voitel Justin s0564500@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen
19: 565517 Ha Le s0565517@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
20: 565873 Al Mohamad Hasan s0565873@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen
21: 566367 Baloska Diro s0566367@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 8 zugelassen
22: 568194 Kolev Dimitar s0568194@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
23: 568851 Springborn Kevin s0568851@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
24: 568927 Solihin Martin Christian s0568927@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
25: 570766 Alkhodor Salim s0570766@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 zugelassen
26: 571336 Hedemann Katja Gertrud s0571336@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 6 zugelassen
27: 572745 Pötsch Michelle s0572745@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 5 zugelassen
28: 572933 Siewertsen Paul s0572933@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen
29: 573063 Unverzagt Laura Laetitia s0573063@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 5 zugelassen
30: 574153 Hahn Hendrik s0574153@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen
31: 575518 Hintze Carolin s0575518@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen
32: 575888 Katysheva Daria s0575888@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 7 zugelassen
33: 575923 Lüdecke Lukas Daniel s0575923@htw-berlin.de Bachelor IMI (B) H Wintersem. 2011 4 zugelassen
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)