const regex = /^(\+44|0044|0)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+44|0044|0)', 'gm')
const str = `+4448798
00448383
0383393`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}