$re = '/^(\+44|0044|0)/m';
$str = '+4448798
00448383
0383393';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);