#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.*[^\.]$)((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.?){4}$"
Local $sString = "999.999.999.999" & @CRLF & _
"299.299.299.299" & @CRLF & _
"199.199.199.344" & @CRLF & _
"192.168.1.123" & @CRLF & _
"255.255.255.255" & @CRLF & _
"" & @CRLF & _
"0.0.0.0" & @CRLF & _
"000.000.000.000" & @CRLF & _
"67.98.159.39" & @CRLF & _
"087.052.078.23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")