import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[^\\.]$)((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.?){4}$";
final String string = "999.999.999.999\n"
+ "299.299.299.299\n"
+ "199.199.199.344\n"
+ "192.168.1.123\n"
+ "255.255.255.255\n\n"
+ "0.0.0.0\n"
+ "000.000.000.000\n"
+ "67.98.159.39\n"
+ "087.052.078.23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}