package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+@\S+`)
var str = `andrew garfield invited as andrew@gomail.com or man@ohman.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}