re = /\S+@\S+/
str = 'andrew garfield invited as andrew@gomail.com or man@ohman.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end