re = /Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)/
str = ' Military
914,519
+97.5% Magic Effectiveness Rune Production
0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end