#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?://www\.facebook\.com/(?:video\.php\?v=\d+|.*?/videos/\d+))$"
Local $sString = "https://www.facebook.com/video.php?v=100000000000000" & @CRLF & _
"https://www.facebook.com/username1/videos/100000000000000" & @CRLF & _
"https://www.facebook.com/username2/videos/100000000000000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")