re = /^(https?:\/\/www\.facebook\.com\/(?:video\.php\?v=\d+|.*?\/videos\/\d+))$/m
str = 'https://www.facebook.com/video.php?v=100000000000000
https://www.facebook.com/username1/videos/100000000000000
https://www.facebook.com/username2/videos/100000000000000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end