#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){3})(?=(?:[^\d\n]*\d){3})[^\x22]{8,32}$"
Local $sString = "2ab3cd1poi" & @CRLF & _
"2ab3cd1"woi" & @CRLF & _
"aaa" & @CRLF & _
"12314564654" & @CRLF & _
""123abcsdfdfsdf" & @CRLF & _
"sdflkjlkjvdlskjvlsdjv" & @CRLF & _
"123abc1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")