$re = '/^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){3})(?=(?:[^\d\n]*\d){3})[^\x22]{8,32}$/m';
$str = '2ab3cd1poi
2ab3cd1"woi
aaa
12314564654
"123abcsdfdfsdf
sdflkjlkjvdlskjvlsdjv
123abc1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);