import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w.*?)(?: (?:[JjSs]r\\.|[XVICMD]+\\b))?,";
final String string = "O'Kefe,Shiley\n"
+ "Folenza,Mitchel V\n"
+ "Briscoe Jr.,Sanford Ray\n"
+ "Andade-Alarenga,Blnca \n"
+ "De La Cru,Feando\n"
+ "Carone,Letca Jo\n"
+ "O'Conor,Mole K\n"
+ "Daeron III,Lawence P\n"
+ "Randall,Jason L\n"
+ "Esquel Mendez,Mara D\n"
+ "Dinle III,Jams E\n"
+ "Coras Sr.,Cleybr E\n"
+ "Hsieh-Krnk,Caolyn E\n"
+ "Graves II,Theodore R\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}