re = /^(\w.*?)(?: (?:[JjSs]r\.|[XVICMD]+\b))?,/m
str = 'O\'Kefe,Shiley
Folenza,Mitchel V
Briscoe Jr.,Sanford Ray
Andade-Alarenga,Blnca
De La Cru,Feando
Carone,Letca Jo
O\'Conor,Mole K
Daeron III,Lawence P
Randall,Jason L
Esquel Mendez,Mara D
Dinle III,Jams E
Coras Sr.,Cleybr E
Hsieh-Krnk,Caolyn E
Graves II,Theodore R
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end