re = /^(?=.*\bmeat\b)(?=.*\bpasta\b)(?=.*\bdinner\b).+/
str = 'hello meat pasta dinner what?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end