$re = '/\>[\s]+\</';
$str = '<html>
<body>
<div> hello </div>
</body>
</html>';
$subst = "><";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;