re = /\>[\s]+\</
str = '<html>
<body>
<div> hello </div>
</body>
</html>'
subst = '><'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result