import re
regex = re.compile(r"^[a-zA-Z0-9](?:[\._-](?=[a-zA-Z0-9])|[a-zA-Z0-9])+@(?:[\._-](?=[a-zA-Z0-9])|[a-zA-Z0-9])+(?:[a-z]{2,4}|com|ru|by)$", flags=re.IGNORECASE)
test_str = "vasya-pupkin@mail.com"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")