re = /^[a-zA-Z0-9](?:[\._-](?=[a-zA-Z0-9])|[a-zA-Z0-9])+@(?:[\._-](?=[a-zA-Z0-9])|[a-zA-Z0-9])+(?:[a-z]{2,4}|com|ru|by)$/i
str = 'vasya-pupkin@mail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end