$re = '/^\d{2}\.\d{2}\b.*\K\R\*\*/m';
$str = '07.00 Tom and Jerry
08.00 She is Just Like Others
**Series about young girl...**
09.00 Regional
09.30 Narava zdravi tržnica – Mic Mengeš, oddaja o zdravju
10.00 POP Hits
**Best music all over the world**
11.00 Alaska
12.00 Sport News
**All actual news from sports all over the world**
13.00 Morning news';
$subst = "\*\*...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;