import Foundation
let pattern = #"^\d{2}\.\d{2}\b.*\K\R\*\*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
07.00 Tom and Jerry
08.00 She is Just Like Others
**Series about young girl...**
09.00 Regional
09.30 Narava zdravi tržnica – Mic Mengeš, oddaja o zdravju
10.00 POP Hits
**Best music all over the world**
11.00 Alaska
12.00 Sport News
**All actual news from sports all over the world**
13.00 Morning news
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\*\*..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)