import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[A-Za-z0-9+]+)(?:[._-]{1}[A-Za-z]+)*)([._-]{1}(?:[+-_\\dA-Za-z.]*)*)*$";
final String string = "AbCd_V13.1.6_WIN32_X64\n"
+ "Efgh-1.28.1\n"
+ "IjKl400f-ABC-_0_1_1\n"
+ "mno_pqr_2002.07.03_16.29h_ab\n"
+ "stuv_2003.02.05_14.06h_WX_Yzab\n"
+ "ef-ghij-klmn-op-5.12.1-qrst-uvw\n"
+ "Xyzab\n"
+ "Defgh_1_11_0\n"
+ "Ijkl_mno_20100319_115358\n"
+ "Pqrs1679_0_1_5\n"
+ "tuvw++_2008.12.02_09.56h_ghe\n"
+ "xyz_abcd_19_3\n"
+ "efgh3.5.12_200603\n"
+ "ijkl-windows10-ver11x2_0-1.0.0\n"
+ "mnop-windows10_11x2ijkl-ver8.1.0.77-1.0.0\n"
+ "Qrst-UvWx-2.0.3+YzAbcd3.4.7\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}