import re
regex = re.compile(r"^((?:[A-Za-z0-9+]+)(?:[._-]{1}[A-Za-z]+)*)([._-]{1}(?:[+-_\dA-Za-z.]*)*)*$", flags=re.MULTILINE)
test_str = ("AbCd_V13.1.6_WIN32_X64\n"
"Efgh-1.28.1\n"
"IjKl400f-ABC-_0_1_1\n"
"mno_pqr_2002.07.03_16.29h_ab\n"
"stuv_2003.02.05_14.06h_WX_Yzab\n"
"ef-ghij-klmn-op-5.12.1-qrst-uvw\n"
"Xyzab\n"
"Defgh_1_11_0\n"
"Ijkl_mno_20100319_115358\n"
"Pqrs1679_0_1_5\n"
"tuvw++_2008.12.02_09.56h_ghe\n"
"xyz_abcd_19_3\n"
"efgh3.5.12_200603\n"
"ijkl-windows10-ver11x2_0-1.0.0\n"
"mnop-windows10_11x2ijkl-ver8.1.0.77-1.0.0\n"
"Qrst-UvWx-2.0.3+YzAbcd3.4.7\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")