re = /.+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n/
str = '2. Unit test (2 points)
Test checkCharacter("word", 3).equals("Character \'d\' is a letter")
Edit
Clone
Remove
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end