using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^.*?/f|\G(?!^))/\K[^/?]+";
string input = @"https://example.com/category/f/filter-1/filter2/filter-3/?orderby=price
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}