$re = '~(?:^.*?/f|\G(?!^))/\K[^/?]+~';
$str = 'https://example.com/category/f/filter-1/filter2/filter-3/?orderby=price
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);