$re = '/(?!^-)\D/m';
$str = '--9d -4h 3m-
1-22
1-22-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);