import re
regex = re.compile(r"(?!^-)\D", flags=re.MULTILINE)
test_str = ("--9d -4h 3m-\n"
"1-22\n"
"1-22-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")