re = /(?<=(|G|M|K|h|da|d|c|m|u|n))(?=(m|g|s|A|K|mol|cd)\b)/
str = 'G, M, k, h, da, d, c, m, u, n
m, g, s, A, K, mol, cd
132mmol
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end