#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(-|)\d{2}\1\d{2}$"
Local $sString = "Which should match against" & @CRLF & _
"" & @CRLF & _
"12-34-56" & @CRLF & _
"123456" & @CRLF & _
"But not against" & @CRLF & _
"" & @CRLF & _
"12-3456" & @CRLF & _
"1234-56"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")