$re = '/^\d{2}(-|)\d{2}\1\d{2}$/m';
$str = 'Which should match against
12-34-56
123456
But not against
12-3456
1234-56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);