package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)([:space:]\:[:space:])(.+)$`)
var str = `Azertyuiop : qsdfghjklm
Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}