using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[12][0-9]{2}(0[1-9]|1[0-2])(2[AB]|[0-9]{2})[0-9]{3}[0-9]{3}([0-9]{2})";
string input = @"187089932132111 ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}