re = /[12][0-9]{2}(0[1-9]|1[0-2])(2[AB]|[0-9]{2})[0-9]{3}[0-9]{3}([0-9]{2})/
str = '187089932132111 '
# Print the match result
str.match(re) do |match|
puts match.to_s
end