re = /<string>(.*?)<\/string>/
str = '<map>
<entry>
<string>id</string>
<string>555</string>
</entry>
<entry>
<string>label</string>
<string>Need This Value</string>
</entry>
<entry>
<string>key</string>
<string>748</string>
</entry>
</map>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end