$re = '/(?:\d++|[a-z]++)\K(?!$)/m';
$str = 'foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);