re = /(?:\d++|[a-z]++)\K(?!$)/m
str = 'foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end