$re = '/\d(?=,|$)/m';
$str = '222.000000000000000000:1:3,222.000000000000000000:1:3,225.000000000000000000:1:1,222.000000000000000000:1:3,222.000000000000000000:1:3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);