re = /\d(?=,|$)/m
str = '222.000000000000000000:1:3,222.000000000000000000:1:3,225.000000000000000000:1:1,222.000000000000000000:1:3,222.000000000000000000:1:3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end