$re = '/(?<=[0-9a-z*])(?=\|)|(?<=\|)(?=[0-9a-z*])/';
$str = '20.558**|50cos|0.5|20sin|20.55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);